Problem with 20050106 snapshot

David Rothenberger daveroth@acm.org
Tue Jan 11 21:59:00 GMT 2005


On 1/8/2005 6:53 PM, Christopher Faylor wrote:
> On Sat, Jan 08, 2005 at 03:06:21PM -0800, David Rothenberger wrote:
> 
>>I'm having a problem with the 20050106 snapshot as well as my own
>>DLL build from CVS HEAD on 20050107. 
>>
>>The problem is with bash killing native processes. I have a bash
>>script that starts a native process in the background, installs a
>>signal handler for SIGINT, grabs the pid from the background
>>process, and then issues wait. The signal handler tries to kill the
>>pid that was captured.
>>
>>With 1.5.12 and a DLL built from CVS on 11/19/2004, this works just
>>fine. With the latest snapshot, I often (but not always) get a "Bad
>>file descriptor" error from kill.
> 
> I tightened up some of the errno setting and will be checking in some
> new code to deal with some problems that Pierre found with windows
> processes, soon.

The latest set of changes in CVS solve this problem for me. At least, I 
don't see the "Bad file descriptor" error anymore.

Thanks!

-- 
David Rothenberger                spammer? -> spam@daveroth.dyndns.org
GPG/PGP: 0x7F67E734, C233 365A 25EF 2C5F C8E1 43DF B44F BA26 7F67 E734



--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list