SSH client hang running uncompressed tar on various servers

Dave Wang
Mon Jan 10 17:36:00 GMT 2005


Just a few quick thoughts come to mind.

-- Have you tried other ssh clients (putty)?
-- have you tried logging into the terminal, and then executing the
command there?
-- if logging into the terminal and executing the command also locks up
on lots of output, try reducing the terminal size to 3 lines, and piping
the output to the "less" command.  If this works, then it may be mtu
issues where a router is dropping ip fragments.

The third comment is a long shot, but I've actually experienced it


-----Original Message-----
From: Brett Porter [] 
Sent: Monday, January 10, 2005 3:09 AM
Subject: SSH client hang running uncompressed tar on various servers


I'm having a problem with my SSH client hanging executing a remote
command extracting an uncompressed tar. This occurs on different
servers (FreeBSD, localhost Cygwin SSHD, RHL9), though they are all
SSH2 and I've using the same private DSA key.

Given this, it isn't the tar executable (though I turned off my virus
scanner just in case). I know this has worked in the past, though I'm
not sure at what point it may have stopped. It happens on both my
machines, and I've had reports from other cygwin users using Maven.

Does anyone have any ideas, or seen it happen? I've had trouble
finding anything beyond virus scanners in the archives and

The SSH version:
OpenSSH_3.9p1, OpenSSL 0.9.7e 25 Oct 2004

 1114k 2004/11/10 C:\cygwin\bin\cygwin1.dll
    Cygwin DLL version info:
        DLL version: 1.5.12

(I'm at the latest of what's installed - if there is any more info I
could provide, please let me know).

The exact command run is:
ssh -vvv -l brett 'cd /home/brett/test-dir;tar xf

The output with -vvv is:
    [exec] debug1: Authentication succeeded (publickey).
    [exec] debug2: fd 4 setting O_NONBLOCK
    [exec] debug2: fd 5 setting O_NONBLOCK
    [exec] debug2: fd 6 setting O_NONBLOCK
    [exec] debug1: channel 0: new [client-session]
    [exec] debug3: ssh_session2_open: channel_new: 0
    [exec] debug2: channel 0: send open
    [exec] debug1: Entering interactive session.
    [exec] debug2: callback start
    [exec] debug2: client_session2_setup: id 0
    [exec] debug1: Sending command: cd /home/brett/test-dir;tar xf
    [exec] debug2: channel 0: request exec confirm 0
    [exec] debug2: callback done
    [exec] debug2: channel 0: open confirm rwindow 0 rmax 32768
    [exec] debug2: channel 0: rcvd adjust 131072
    [exec] debug1: client_input_channel_req: channel 0 rtype exit-status
reply 0

    [exec] debug2: channel 0: rcvd eof
    [exec] debug2: channel 0: output open -> drain
    [exec] debug2: channel 0: rcvd close
    [exec] debug2: channel 0: close_read
    [exec] debug2: channel 0: input open -> closed
    [exec] debug3: channel 0: will not send data after close
this is where is always stops. I have to kill the process - Ctrl-C
doesn't work.

BTW, I'm back to the cygwin list after a long time away - it's been so
stable for years. Great job all - I couldn't work day to day on
Windows without it :)


Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list