sshd under Cygwin

pedal2metal pedal2metal@sbcglobal.net
Sun Jan 2 07:31:00 GMT 2005


Hello,
   Ok, I installed all of Cygwin & then attempted to get sshd running.  I
did this about 1.5 years ago
& it didn't seem too hard so I thought I try again.  Anyhow, this time, I've
grown a bit & use the RSA keys
of SSH Protocol 2 as my standard method so I wanted to do that this time.
   Well I ran ssh-host-config & everything looked good but only password
authentication worked.
After lots of mistakes, false starts, I figured out my /home/<UserName>
directory rights were wrong &
ran ssh-user-config to fix them which removed write priveleges for
group/world.  Still no RSA keys allowed.
Anyhow, now I'm afraid I've made a total mess of things.  I read the
/usr/share/doc/Cygwin/openssh.README file
which is how I got this email address.
I ended up trying to "reset" things.  I deleted my .ssh directory.  I
removed the "sshd" service via regedit.
I removed the "sshd" user also via Control Panel.  I then ran
ssh-user-config, regenerated my RSA SSH Protocol 2 keys, then
ran ssh-host-config & said yes to everything & I have CYGWIN='ntsec tty'.
Still no luck.  I can only connect by using my password.  I'm using the "ssh
127.0.0.1" test as my reference.
I'm guessing this whole process is a "do-once" &
once you screw it up, it can't be undone short of a complete Cygwin
re-install and/or Windows re-install, although
honestly, I have no clue.  I've done Google, read tons of emails, threads,
read the /usr/share/doc area, etc... still
no fundamental clue on the deterministic process to get RSA2 keys working
reliably with sshd under Cygwin.
I'm running Windows 2000 Pro SP4 & using a February 25,2004 archive of the
redhat mirror for the Cygwin install.

I am operational since I can use my password but I'm completely baffled by
why the RSA2 keys don't work since
I use them on my other systems which I use SSH for.

thanks & best regards,

Eric Rose


--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list