Installing Perl modules with "perl -MCPAN -e shell;" fails with "02packages.details.txt.gz does not contain a Line-Count header"

Brian Dessent
Sun Feb 27 05:56:00 GMT 2005

Stephan Petersen wrote:

> >>Please check the validity of the index file by comparing it to more
> >>than one CPAN mirror.
> >
> > Have you tried this?  E.g. configured CPAN to use another mirror and tried
> > again?
> yes, it's the same for every CPAN mirror I've tried. I've deleted CPAN's
> and my .cpan directory several times now, it's the same after
> every reconfiguration.
> Testing 02packages.details.txt.gz with gzip -t reports:
> gzip: 02packages.details.txt.gz: invalid compressed data--format violated
> Same with
> I'm using cygwin on W2k with default text file type "DOS", in case
> that's relevant.

If you're using ftp mirrors try using a http mirror.  It could be that
some kind of gateway, proxy, or firewall sees ".txt" in the filename and
uses ascii mode for the ftp session, instead of binary.  As an
experiment, try getting both of the following links and see if one is
corrupt and the other not:

If there is a difference then switch to using a http mirror, or change
the ftp client that perl/cpan is using (e.g. Net::FTP, wget, curl, lftp,


Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list