Installing Perl modules with "perl -MCPAN -e shell;" fails with "02packages.details.txt.gz does not contain a Line-Count header"

David Christensen dpchrist@holgerdanske.com
Sun Feb 27 04:40:00 GMT 2005


Stephan Petersen wrote:
>>>Please check the validity of the index file by comparing it to more
>>>than one CPAN mirror.
>> Have you tried this?  E.g. configured CPAN to use another mirror and
>> tried again?
> yes, it's the same for every CPAN mirror I've tried. I've deleted
> CPAN's config.pm and my .cpan directory several times now, it's the
> same after every reconfiguration.
> Testing 02packages.details.txt.gz with gzip -t reports:
> gzip: 02packages.details.txt.gz: invalid compressed data--format
> violated
> Same with 03modlist.data.gz.
> I'm using cygwin on W2k with default text file type "DOS", in case
> that's relevant.

Hmmm...  I dunno.  I run Win XP Pro with Cygwin in DOS mode, and my CPAN seems
to work.  It also worked when I ran Win2k Pro.


I'd move the entire C:\cygwin tree aside, reinstall Cygwin base and the relevant
Perl packages, and give CPAN another try.  (Note that when I wipe and reinstall
Cygwin, I don't try to do anything about Cygwin Registry entries and it seems to
come out okay.)  If CPAN barfs again, then it's probably something other than
Cygwin.  If it works, then it probably was your old Cygwin installation and your
problem is solved.


David


--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list