Directory names

Dave Korn
Mon Feb 21 22:36:00 GMT 2005

> -----Original Message-----
> From: cygwin-owner On Behalf Of Eric Blake
> Sent: 19 February 2005 17:51
> To: Frank Juergen-r58616

> Hash: SHA1
> According to Frank Juergen-r58616 on 2/18/2005 7:30 AM:
> > If my target is powerpc-*-eabin , the compilation works but 
> the installation is the problem. The make file want create an 
> directory with the label of the 
> > target (in this case powerpc-*-eabin ). But Windows didn't 
> accept the star in directorie names ... any solution, for 
> this problem ?
> Have you tried managed mounts?  Search the archives for 
> instructions on
> setting one up (it involves mount -o managed).

  No no no no no no no no no no no no NO!

  First off, even on POSIX, * isn't a valid filename character, so whether or
not a managed mount would permit it, it's still not the right answer.

  The actual problem is that Frank should not use "powerpc-*-eabin" as a target.
You may see target triples written in that form once in a while, but that's a
pattern-match.  The * means that the documentation is referring to "any powerpc
eabin target", not specifying which.  But when you run a configure, you *must*
specify a precise target.  It's no more valid to try and run a configure command
with "--target=powerpc-*-eabin" than it would be to try and configure with
"--target=*-gnu-linux" and hope you'd get a multiprocessor binary!

  So Frank needs to find something to go in the middle there.  "powerpc-*-eabin"
is a specimen target; Frank needs to find the correct triple for his actual
target.  I can't help there: Frank hasn't described what hardware/OS he wants
his cross-binutils to run on, and I've never even heard of 'eabin', so I can't
even begin to offer a guess as to what it should actually be.  Perhaps it's a
slightly mangled version of "powerpc-eabisim"?

Can't think of a witty .sigline today....

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list