Problem with 20050215 snapshot and ssh-agent forwarding

Christopher Faylor
Fri Feb 18 20:08:00 GMT 2005

On Fri, Feb 18, 2005 at 09:30:35AM -0500, Jean-Sebastien Trottier wrote:
>On Wed, Feb 16, 2005 at 11:23:03AM -0800, David Rothenberger wrote:
>> I'm having a problem with the 20050215 snapshot (and the 20050131 as
>> well). My ssh-agent connection is not being forwarded by ssh. This is
>> working fine with the 20041119 snapshot.
>> Here are the steps to reproduce the problem. I've got ssh and sshd
>> correctly configured to forward ssh-agent connections. The second ssh
>> command should not prompt to the public key passphrase.
>> % keychain ~/.ssh/id_dsa
>> KeyChain 2.0.3;
>>  Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
>>  * All previously running ssh-agent(s) have been stopped.
>>  * Initializing /home/drothe/.keychain/tela-sh file...
>>  * Initializing /home/drothe/.keychain/tela-csh file...
>>  * Starting new ssh-agent
>>  * 1 more keys to add...
>> Enter passphrase for /home/drothe/.ssh/id_dsa:
>> Identity added: /home/drothe/.ssh/id_dsa (/home/drothe/.ssh/id_dsa)
>> % . ~/.keychain/tela-sh
>> % ssh `hostname`
>> % ssh `hostname`
>> Enter passphrase for key '/home/drothe/.ssh/id_dsa':
>Have you tried " ssh -A `hostname` " instead... just to make sure the
>ssh actually forwards the agent?

Why would he have to do that?  The first one worked.  The second one failed.

>If this works (and it should), add "ForwardAgent yes" to your
>~/.ssh/config file. see "man ssh_config" for details

Ditto this.  If the first invocation works then I don't think there is any
reason to suspect configuration problems.


Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list