Unable to delete a number of directories...

Aitken, Sean Sean.Aitken@tekelec.com
Thu Feb 17 12:15:00 GMT 2005

> >My guess is that it's a Windows NTFS permissions issue.  
> Assuming you want to
> >blow away the entire C:\cygwin tree and start again fresh:  log on as
> >Administrator, take ownership recursively of the entire 
> tree, and reset
> >permissions recursively of the entire tree.  You then should 
> be able to delete
> >it.
> I'm running XP. Never come across this before. I do have 
> admin rights (this 
> is my own home machine). I've tried with Windows Explorer and Windows 
> Commander - I can't even remove the read-only attribute on the file.
> Only thing I see when right clicking that folder is 
> properties, and if I 
> uncheck Read-Only, when I hit apply I get access denied.

Try configuring Cygwin on the server end to use the "nontsec" option.
This causes new files to be created with inherited NT permissions as
opposed to the "Unix-Like" permissions.  I know this has solved a lot of
problems for our team.

Just set or modify the global environment variable "CYGWIN" to be
include 'nontsec'. Ie:


Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/

More information about the Cygwin mailing list