[ANNOUNCEMENT] Updated: zsh-4.2.4-1

Peter A. Castro doctor@fruitbat.org
Sun Feb 13 15:59:00 GMT 2005

On Sat, 12 Feb 2005, zzapper wrote:

> On Fri, 11 Feb 2005 18:42:39 +0000,  wrote:
> Peter,

Hi zzapper,

> I tried various things to make sure I had a completely up to date zsh.
> This is what I did:-
> rm /etc/z*
> mv ~/.z* ~/bak
> del zsh.exe  (actually did this from DOS)
> Then used Cygwin setup.exe  to UNINSTALL zsh.exe
> Then installed via CygWin setup.exe
> REINSTALL didn't worked probably for the same reason my zsh wouldn't upgrade

I can't seem to reproduce your symptoms.  Is it possible that you have
another zsh exe somewhere else in your Windows PATH?  If you un-install
zsh, can you then still run 'zsh' ?  For that matter, once you
un-install, did you verify all exe's were removed?  There was one case
where someone did an install from one account and when they tried
upgrading from another account couldn't do it because of file
ownership/permissions issues.

I'd recommend running uninstall first, then delete whatever's left over
(and making sure the files were really removed) and then installing.
Beyond that, I can't think of any reason why an older version would so
stubornly stick around, unless you have two cygwin homes and they are
both in your Windows PATH.

> zzapper (vim, cygwin, wiki & zsh)
> --
> vim -c ":%s%s*%CyrnfrTfcbafbeROenzSZbbyranne%|:%s)[R-T]) )Ig|:norm G1VGg?"

Peter A. Castro <doctor@fruitbat.org> or <Peter.Castro@oracle.com>
	"Cats are just autistic Dogs" -- Dr. Tony Attwood

Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/

More information about the Cygwin mailing list