cygheap version mismatch ?

Sun Feb 13 04:33:00 GMT 2005

It looks like I have managed to screw up my cygwin installation
more or less completely :o(

What I did: I was trying out some of the latest snapshots, and
noticed that KDE would not start with them. So I kept trying,
changing back and forth between the different cygwin1.dll files,
rebooting and running rebaseall -v between tries.

Result: Now, whenever I try starting XWin (whether with KDE or
without) it will fail with the message such as the following:

C:\cygwin\usr\X11R6\bin\XWin.exe (4056): *** cygheap version
   mismatch detected - 0x61790000/0x1010000.
You have multiple copies of cygwin1.dll on your system.
Search for cygwin1.dll using the Windows Start->Find/Search facility
and delete all but the most recent version.  The most recent version *should*
reside in x:\cygwin\bin, where 'x' is the drive on which you have
installed the cygwin distribution.

I have tried putting the original cygwin1.dll back, including
reboot and rebaseall -v, but still the same results.

As it is, the only thing I can do is run bash in a dos window.

There are definitely no multiple copies of that file. I renamed
all the other snapshopts to <something_else>._dll and searched all

Any pointers or advice would be greatly appreciated.

Cheers CV

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list