Setup.exe 2.457.2.2: spin button won't allow me to reinstall coreutils

Thomas Nilsson
Sat Feb 12 22:50:00 GMT 2005

"Reini Urban" <> skrev i meddelandet
> Steve Munson schrieb:
>> Installing the newest version of cygutils (1.2.6-1) removed
>> /bin/readlink, as explained in the ChangeLog entry for 1/31/05. I
>> thought the remedy would be to reinstall coreutils (5.2.1-5), which
>> cygcheck now reported as incomplete. However, setup.exe refused to
>> reinstall it. The spin button only presented the options to Keep 
>> and
>> Uninstall, no matter which view I used. Finally, I used the spin 
>> button
>> on the Base category in the Category view to select Reinstall for 
>> the
>> whole category, and then selected Keep for the rest of the packages 
>> in
>> the Base category individually. Clicking the Next button displayed 
>> a
>> message box with this error:
>> Fatal Error: Uncaught Exception
>> Thread: install
>> Type: St16invalid_argument
>> Message: URL Scheme not registered!
> Thanks for the report.
> Filed as bug #717
> -- 
> Reini Urban

The above problem seems akin to the following which I encountered.

cygcheck reported shellutils and xpm as Incomplete. I tried to 
Reinstall them but only Remove and Keep was available. Selected 
Reinstall on the whole cathegory (Misc). Running that displayed a 
dialog box with the message: "Can't open (null) for reading. No such 

Setup.exe is 2.457.2.2

Solved my problem by clicking OK. This lead to someother packages 
being Incomplete but these did Reinstall second time around.


Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list