perl & Win32 lib support

Yitzchak Scott-Thoennes
Fri Feb 11 02:31:00 GMT 2005

On Thu, Feb 10, 2005 at 11:29:43AM -0800, linda w wrote:
> Am having problems with trying fixes for the below errors --
> once I encounter an error in making Win32, I can correct the source
> files in another window, but I then it won't let me run "make" on
> Win32 again w/o force because it already encountered an error.
> If I do a make force, it re-unpacks the source files over my changes.
> If I try to do the make by hand, I must not have my INC path setup,
> as I get a missing "" when trying to "make" outside of
> cpan.
> Gerrit P. Haase wrote:
> >Then -L/usr/lib/w32api is missing in hints/
> I tried adding line back in, but it didn't seem to make a difference.
> It seems like it is unpacking into 1 place: build/libwin32-0.191
> but then building parts of it in GSAR000[0-4]/...
> Sorry...but am a bit unclear about where it is copying and building
> sources...makes it difficult to do things manual at this point.

Um, you aren't going to have a lot of success building libwin32 from
CPAN afaik.  Your options are really

1) use the cygwin perl-libwin32 package, with a
"use lib '/usr/lib/perl5/site_perl/5.8.2';" at the beginning of your
code or via the PERL5LIB var (see perldoc perlrun)

2) get the source for the perl-libwin32 and the other packages necessary
and try to build it (there will be a few failures)

3) wait for an updated perl-libwin32 release (should be soon)
> >>4) Warning: prerequisite Win32API::Registry 0 not found.
> >>  Writing Makefile for Win32::TieRegistry
> >
> ----
>    What's the warning/prereq not found message about?

Just a side effect of libwin32 being assembled from several independent
parts.  Win32API::Registry is in fact included with libwin32.
> >>
> >>5) make[2]: Entering directory 
> >>`//ishtar/share/CPAN/build-cygwin/GSAR001/libwin32-0.191/APIFile'
> >>Makefile:705: *** missing separator.  Stop.
> >>
> >This is annoying, I get it occasionally, I believe it is a bug in
> >MakeMaker, but I couldn't find it yet.  Does the build continue if you 
> >add the missing tab and run make again?
> Where / how can I run make again within the cpan context?  Is there
> a perlvar I can change using "!" in cpan to tellit to forget the fact
> that make just failed?  Sorry, not a cpan expert bumbling
> around in the jungle here...:-/

Use the "look Win32" command in the cpan shell.  I've had that
sometimes not work; if it doesn't, just start another shell and cd to
the directory cpan is doing the build in (probably

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list