perl & Win32 lib support

linda w cygwin@tlinx.org
Fri Feb 11 01:12:00 GMT 2005


Am having problems with trying fixes for the below errors --
once I encounter an error in making Win32, I can correct the source
files in another window, but I then it won't let me run "make" on
Win32 again w/o force because it already encountered an error.

If I do a make force, it re-unpacks the source files over my changes.
If I try to do the make by hand, I must not have my INC path setup,
as I get a missing "Config.pm" when trying to "make" outside of
cpan.

Gerrit P. Haase wrote:

> Then -L/usr/lib/w32api is missing in hints/cygwin.pl.

I tried adding line back in, but it didn't seem to make a difference.
It seems like it is unpacking into 1 place: build/libwin32-0.191
but then building parts of it in GSAR000[0-4]/...
Sorry...but am a bit unclear about where it is copying and building
sources...makes it difficult to do things manual at this point.

>> 4) Warning: prerequisite Win32API::Registry 0 not found.
>>   Writing Makefile for Win32::TieRegistry
>
----
    What's the warning/prereq not found message about?

>>
>> 5) make[2]: Entering directory 
>> `//ishtar/share/CPAN/build-cygwin/GSAR001/libwin32-0.191/APIFile'
>> Makefile:705: *** missing separator.  Stop.
>>
> This is annoying, I get it occasionally, I believe it is a bug in
> MakeMaker, but I couldn't find it yet.  Does the build continue if you 
> add the missing tab and run make again?

Where / how can I run make again within the cpan context?  Is there
a perlvar I can change using "!" in cpan to tellit to forget the fact
that make just failed?  Sorry, not a cpan expert here...am bumbling
around in the jungle here...:-/

Linda


--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list