cygheap problems, also on version 1.5.9 (was Re: cygheap problems, 20040326 snapshot)

Andy Rushton
Mon Mar 29 15:07:00 GMT 2004

I'm having similar problems with release 1.5.9. I thought that if I 
posted more information it might help to pin down the problem.

I have just done a complete clean reinstall of Cygwin (i.e. deleted the 
directory and registry settings first) using the net installer and 
therefore using the 'official' releases of all packages. The 
cygcheck.out fiile is attached if you need to know more. I'm running 
under XP (you're always 'under' Windoze) with all the latest patches and 
updates. So, the buggy version then.

Consider the following sequence typed in under the DOS shell:

H:\Documents and Settings\Andy>bash --login -c XWin
      4 [main] ? 476 cygheap_fixup_in_child: Couldn't reserve space for 
cygwin's heap (0x616E0000 <0x7E0000>) in child, Win32 error 487
H:\cygwin\usr\X11R6\bin\XWin.exe (476): *** m.AllocationBase 0x0, 
m.BaseAddress 0x616E0000, m.RegionSize 0x1AA0000, m.State 0x10000

H:\Documents and Settings\Andy>bash --login

$ XWin

The latter command worked fine.

I've tried running 'rebaseall' and it made no difference. Mind you, 
should it do anything on a completely fresh build?

The really odd thing is that I have another PC at home with the same 
version of XP, same update status and as far as I can tell, the same 
install of Cygwin and I have no problems.

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: cygcheck.out
URL: <>
-------------- next part --------------
Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list