Using gcc 3.3.3

Ben Taylor
Sun Mar 14 19:23:00 GMT 2004


I have got Cygwin running on my windows XP pc, using gcc 3.3.1. I downloaded
gcc 3.3.3 release, and managed to build it, however when I tried to compile
a windows application using it it compiled ok but gave a linker error
'couldn't find crt2.o'. It gave this error when I was trying to compile
with -mno-cygwin, which worked with gcc 3.3.1. I found that this file was in
c:/cygwin/lib/mingw, but passing an option on to the linker such
as -Wl,"-Lc:/cygwin/lib/mingw" or other variations on this didn't work.
However when I copied the crt2.o file to c:/cygwin/lib, it worked! But then
I read that -mno-cygwin wasn't  included on gcc 3.3.3. So was this a fluke?
Or is there a standard way to use gcc 3.3.3 on cygwin?

Also if I used g++ 3.3.3 to compile but g++ 3.3.1 that came with cygwin to
link, it also works fine! Is it then actually using the benefits of the more
modern version?

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list