dvips failing to include cmdunh10 font definition

Tim Reid c_for_yourself@hotmail.com
Tue Mar 9 17:13:00 GMT 2004

I believe I have found a problem with dvips. If I run LaTeX against the
following file:



This is in the normal Computer Modern font.
{\anewfont This is in the vertically expanded Computer Modern font.
It looks fine in the DVI viewer.}

However, when using:
\texttt{dvips(k) 5.92b Copyright 2002 Radical Eye Software
it gets replaced with a fixed-width font, but using the correct letter
spacings. This means that it looks {\anewfont very odd indeed}.


I get a DVI file which looks just fine, and displays just fine using
MiKTeX's Yap viewer. Furthermore, when I run dvips from the MiKTeX
distribution on it, it produces a PostScript file which looks fine.

However, when I run dvips from the teTeX package in Cygwin on the same
DVI file, the resultant PostScript file displays and prints wrongly,
with the wrong font used for the bit which should be cmdunh10. Looking at
the PostScript messages produced in GSview, it seems to be substituting
Courier, as CMDUNH10 isn't defined. Examining the PostScript file, there
seems to be no definition of the cmdunh10 font, although it looks as if
dvips is trying to include one. The file contains the following extract:

%%BeginFont: CMDUNH10
%%BeginFont: CMR10
%!PS-AdobeFont-1.1: CMR10 1.00B
%%CreationDate: 1992 Feb 19 19:54:52

So the cmdunh10 definition is just not there. Is anyone able to reproduce
this problem?

Tim Reid

Tired of 56k? Get a FREE BT Broadband connection 

Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/

More information about the Cygwin mailing list