zsh 4.1.1-3 on W2000 hangs with command not found

Peter A. Castro doctor@fruitbat.org
Mon Mar 8 21:55:00 GMT 2004


On Mon, 8 Mar 2004, Thorsten Kampe wrote:

> * Christopher Faylor (2004-03-08 15:05 +0100)
> > On Mon, Mar 08, 2004 at 02:56:20PM +0100, Thorsten Kampe wrote:
> >>* Christopher Faylor (2004-03-08 14:43 +0100)
> >>> On Mon, Mar 08, 2004 at 01:55:31PM +0100, Thorsten Kampe wrote:
> >>>>* Davide Marchignoli (2004-03-08 11:38 +0100)
> >>>>>Zsh hangs when running a non-existent command.  It usually hangs as
> >>>>>soon as you give a non existing command, however sometimes it works
> >>>>>correctly two or three times and then hangs.
> >>>>
> >>>>What do you mean by "non-existant" command?
> >>>>
> >>>>>I am running zsh also on Win XP and there it behaves correctly.
> >>>>
> >>>>Some people were already describing similar things (including me).
> >>>
> >>> Yes.  This problem was reported within 48 hours after 1.5.7 was released.
> >>> It was reported as a problem which existed in 1.5.6, for which the reporter
> >>> was waiting for a fix to appear even though the problem was not reported.
> >>>
> >>> The problem was fixed within a few hours after being reported and has been
> >>> fixed in snapshots ever since.
> >>>
> >>> So, download a snapshot or wait for 1.5.8.  1.5.8 is due to be released in
> >>> 2004.
> >>
> >>I'm already running the snapshot from "2004-Mar-05" (and now
> >>downloading the one from "2004-Mar-06") all the 1.5.8 snapshots I
> >>tried didn't fix that.
> >
> > Nope.  You are mistaken.  It works fine.  In fact, on checking the archives
> > you even told someone to use the snapshot to fix this problem.
>
> Yeah, that was to someone who had problems "1) sometimes when I start
> zsh it hangs, sometimes it starts normally; (2) zsh command-line
> editing generally badly messes up the display when long command lines
> are being edited"
>
> I never had these problems myself so I told him to upgrade instead of
> downgrade (what the zsh maintainer advised).

I figured I'd better weigh in here on this before my words get used in
someone elses battle. :)

For the record, I've advocated both downgrading to 1.5.5 or using the
latest snapshot, depending on the users environment, skill and needs.
My debate with Larry Hall on this is in the archives.

Also, for the record, I've just tried the latest snapshot, 20040306, and
running missing commands do not hang or have any other strange behaviour
as your describe:

(doctor@garfunkel)[101] ~ % les
zsh: correct 'les' to 'ls' [nyae]? n
zsh: command not found: les
zsh: 1240 exit 127   les
(doctor@garfunkel)[102] ~ % /bin/les
zsh: no such file or directory: /bin/les
zsh: 1245 exit 127   /bin/les
(doctor@garfunkel)[103] ~ % uname -a
CYGWIN_NT-4.0 garfunkel 1.5.8s(0.111/4/2) 20040306 23:59:38 i686 unknown unknown Cygwin
(doctor@garfunkel)[104] ~ % cygcheck -s | grep zsh
zsh                     4.1.1-3
(doctor@garfunkel)[105] ~ % setopt | grep correct
correct
correctall
(doctor@garfunkel)[106] ~ %


> > If you truly had a problem I am sure that you would have reported it
> > prior to this point rather than implying that it worked.
>
> This is just a tiny problems for me. There was a real problem with zsh
> where *completion* took a long time (it tried to do DNS lookup -
> according to my Personal Firewall - and timed out when I wasn't online
> and no DNS was available). This is gone. The other "problem" is no
> problem for me because I use the completion and therefor the "correct"
> mechanism is /very rarely/ triggered. After that zsh caches the answer
> and replies immdiately "zsh: no such file or directory". (If I'm so
> dumb to try it again.)

My example above has both correct and correctall on and I don't
experience any problems no matter how many times I try to run a bad
command.  This goes for weither zsh tries to correct the command or not.

> But please be aware that there may be different problems. The one I
> described is with the "correct function" of zsh (and I figured that
> out just today). Davide Marchignoli's problem seems to be different:
>
> % aoidfjkl        # immediately: "zsh: command not found: aoidfjklj"
> % /bin/aoidfjklj  # hangs for about ten seconds until "zsh: no such file or directory: /bin/aoidfjklj"

Sorry, mine returnes immediately, no delay at all.  And this is on an old
400MHz PII running under a vmware emulator.  Oh, and I tried this same
setup, with the latest snapshot on a 1.7Ghz system running MS Windows
native without any problems either.   I also tried both of these on
network mounted drives and didn't have any delays or problems.

I feel you should examine your environment thoroughly.  Perhaps you have
more than one copy of cygwin1.dll in your PATH?  When you last upgraded,
are you sure you existing all cygwin based processes before starting a
new shell window?

> Thorsten

-- 
Peter A. Castro <doctor@fruitbat.org> or <Peter.Castro@oracle.com>
	"Cats are just autistic Dogs" -- Dr. Tony Attwood

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list