Cygwin v1.5.5-1: g++ produces "Entry Point Not Found" error

Igor Pechtchanski pechtcha@cs.nyu.edu
Sat Sep 27 15:14:00 GMT 2003


Ken,

Adding a "." to the end of your PATH and then running "cygcheck -svr"
*from the directory where the problem occurs* would have shown that extra
cygwin1.dll (and its version) in the output.

As a general advice (and I guess we might want to add this to the problem
reporting page), if there's a problem that occurs in a specific directory,
you should run "cygcheck -svr" from that directory in order to eliminate
as many variables as possible.

FWIW, I'm glad this is in the archives, because, frankly, I should have
asked whether the problem also occurs when you compile sources from
another directory.  This will serve as a reminder for next time.
	Igor

On Fri, 26 Sep 2003, Kin Ming Ng wrote:

> Igor,
>    I am definitely very sorry for my previous posting as I realized
> that there is indeed an older copy of cygwin1.dll lying in my C++
> source directory which is located on my D: drive and not in my C:
> drive (which is the drive where cygwin is installed on).
>    I was wondering, wouldn't it be nice if it is possible to perform
> some kind of version check on the dlls before actually looking in a
> *.dll to see if something is there?  In addition, it would be really
> nice if the error message would pinpoint the location of the dll
> containing the error.  But then again, this is just a thought.
>    Hope I didn't cause too much frustration for you.
>
> Ken
>
>
> > Ken,
> >
> > Please make sure your mailer honors the Reply-To: header.
> >
> > FWIW, your cygcheck output looks pretty normal -- I don't see any reason
> > for the messages you're getting.
> >
> > Are you still getting them, BTW?  Did you reboot since you tried g++ last?
> > Did the reboot help?
> >
> > If not, did you search for copies of cygwin1.dll *outside* of your Cygwin
> > tree?  I specifically mentioned them in the last line of my message.
> > 	Igor
> >
> > On Fri, 26 Sep 2003, Kin Ming Ng wrote:
> >
> > >      Sorry that I had forgot to include a cygcheck attachment, here it
> > > is...  In any case, the Cygwin v1.5.5-1 is a fresh installation downloaded
> > > directly from www.cygwin.com using the default setup.exe.  I do wanted to
> > > point out one thing however, I did encounter some problems during the
> > > usage of setup.exe to download "all" of the files first into my computer
> > > to install cygwin.  I had to make several attempts in order to download a
> > > complete setup of "all" the files.  I wonder if this has anything to do
> > > with the problem because I only found 1 copy of cygwin1.dll inside the
> > > installed cygwin directory.
> > >
> > > Ken
> > >
> > >
> > > > On Fri, 26 Sep 2003, Kin Ming Ng wrote:
> > > >
> > > > >      I had successfully compiled several programs with g++ under
> > > > > Cygwin v1.3.20-1.  But upon upgrading to Cygwin v1.5.5-1, the same
> > > > > programs that are compiled with the new g++ produces the error:
> > > > >   "cc1plus.exe - Entry Point Not Found" - in a popup window
> > > > > Inside the error window, it details:
> > > > >   "The procedure entry point __getreent could not be located in the
> > > > > dynamic link library cygwin1.dll"
> > > > >
> > > > >      I had never received this error before and I didn't see a previous
> > > > > posting related to this subject, so I figured I'll post something here.
> > > > > Had I included enough information in this message?  If not, please do ask.
> > > > > Please forgive my naiveness, I'm new.
> > > > >
> > > > > Ken
> > > >
> > > > The guidelines for reporting Cygwin problems are outlined in
> > > > <http://cygwin.com/problems.html>.  It would have helped if you had
> > > > attached (as an uncompressed text *attachment*) the output of "cygcheck
> > > > -svr".
> > > >
> > > > At a guess, you either have an older cygwin1.dll (i.e., you had a Cygwin
> > > > process running while upgrading), or you have more than one copy of
> > > > cygwin1.dll on your system.  The cygcheck output requested above will
> > > > confirm or deny these guesses.  If the former is correct, you should get
> > > > things working after a reboot.  If the latter, simply delete the extra
> > > > (older) copies of cygwin1.dll, leaving only the one in /bin.  Be aware
> > > > that the other copies of cygwin1.dll may not be in the Cygwin tree.
> > > > 	Igor

-- 
				http://cs.nyu.edu/~pechtcha/
      |\      _,,,---,,_		pechtcha@cs.nyu.edu
ZZZzz /,`.-'`'    -.  ;-;;,_		igor@watson.ibm.com
     |,4-  ) )-,_. ,\ (  `'-'		Igor Pechtchanski, Ph.D.
    '---''(_/--'  `-'\_) fL	a.k.a JaguaR-R-R-r-r-r-.-.-.  Meow!

"I have since come to realize that being between your mentor and his route
to the bathroom is a major career booster."  -- Patrick Naughton

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list