segmentation fault with some apps on new cygwin release 1.5.4-1

Igor Pechtchanski pechtcha@cs.nyu.edu
Fri Sep 19 19:52:00 GMT 2003


On Fri, 19 Sep 2003, Joe Vallino wrote:

> I'm running cygwin version 1.3.22-1 on one AMD machine, and all works
> fine.
>
> I recently installed cygwin on another AMD machine, new release 1.5.4-1
> when i try to start xedit i get a segmentation fault.  Also, when I
> compile clisp version 2.30 from sourceforge, it compiles ok, but also
> generates a segmentation fault when run.
>
> If i copy either xedit or clisp executable from the pc running build
> 1.3.22-1, both seem to run ok on the new build.
>
> Sorry this is not much to go on.  I have searched this mailing list, but
> have not found any similar problems.
>
> thanks in advance
> -joe

The xedit crash belongs on the cygwin-xfree list (and has been reported
and discussed there already).

Clisp is now an official Cygwin package -- did you try installing and
running that?  Does it exhibit the same symptoms?

The fact that older executables work most likely indicates a link-time
conflict (older headers, perhaps?).
	Igor
-- 
				http://cs.nyu.edu/~pechtcha/
      |\      _,,,---,,_		pechtcha@cs.nyu.edu
ZZZzz /,`.-'`'    -.  ;-;;,_		igor@watson.ibm.com
     |,4-  ) )-,_. ,\ (  `'-'		Igor Pechtchanski, Ph.D.
    '---''(_/--'  `-'\_) fL	a.k.a JaguaR-R-R-r-r-r-.-.-.  Meow!

"I have since come to realize that being between your mentor and his route
to the bathroom is a major career booster."  -- Patrick Naughton

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list