xdvi: SIGSEGV in XtInitialize

Jan Nieuwenhuizen janneke@gnu.org
Tue Sep 16 12:40:00 GMT 2003


Brian Ford writes:

> Sorry to be so tearse.  Let me explain.
>
> The Xt library has not yet been compiled under Cygwin 1.5.x.  Until it is,
> it is unsafe for use by apps compiled under 1.5.x.  This is a side effect
> of the 64 bit implementation method choice.
>
> Does that help, or is it still to vauge?

That's quite clear.  tetex (and any other packages linking to libXt)
should not have been rebuilt and released for 1.5.x yet.  Executables
such as xdvi will be broken until libXt is available for 1.5.x (when
is this planned to happen?), and those packages must be built again.

We should find out which executables are affected, this fact should be
advertised on the cygwin list, and package maintainers must be
notified on cygwin-apps.

Jan.

-- 
Jan Nieuwenhuizen <janneke@gnu.org> | GNU LilyPond - The music typesetter
http://www.xs4all.nl/~jantien       | http://www.lilypond.org


--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list