xdvi: SIGSEGV in XtInitialize

Jan Nieuwenhuizen janneke@gnu.org
Mon Sep 15 22:07:00 GMT 2003


[tempted to post to -apps, but not breaking the thread just yet]

Brian Ford writes:
> I am sorry you too had to waste your time on this, but I am pretty sure
> that the problem is well summed up in:

> http://www.cygwin.com/ml/cygwin-xfree/2003-09/msg00227.html

Thanks.  Summed-up a bit too well for me, I'm not sure that I fully
understand.

The message suggests that Xt is no longer available, is that so?  Do
you know what consequences that has for packages that used it?

Strange, I tried to rebuild tetex yesterday after upgrading to

    XFree86-bin         4.3.0-2
    XFree86-prog        4.3.0-4

and xdvi had the same problem, so I dismissed that a rebuild would
help.

Ah, but it turns out that (the not-to-be-used-with-1.5.x) libXt.a is
still being shipped in XFree86-prog 4.3.0-4.  Now I'm confused.

> cgf, it looks like even you fell for it somewhat.  Maybe the note to
> cygwin-apps idea wasn't so misplaced. :-)

No, indeed.  I specifically asked at cygwin-apps and I was advised not
to wait for xfree to be rebuilt against 1.5.x before rebuilding and
releasing tetex, which depends on xfree.

Greetings,
Jan.

-- 
Jan Nieuwenhuizen <janneke@gnu.org> | GNU LilyPond - The music typesetter
http://www.xs4all.nl/~jantien       | http://www.lilypond.org


--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list