rxvt hanging after latest cygwin update

Thomas V. Fischer tvfischer_l@worldonline.fr
Mon Sep 8 07:12:00 GMT 2003

Hey all,

I just upgraded my cygwin installation to the new release made available at
the beginning of the month.

Since this upgrade, my rxvt launch script doesn't work anymore.

I have the following dos-batch script:

    start /i /min /separate /b $PATH2CYG\bash --login -c "/startrxvt.sh 12

 The startrxvt.sh script looks like this:


    #Redirect IO to allow parent terminal to closr
    exec 0< /dev/null
    exec 1> ~/.xdmcp-errors
    exec 2>&1

    # Select font size
    if [ -n "$1"]; then FONTSIZE=$1; fi

    rxvt -bg black -fg green -fn "-*-Lucida
Console-*-*-*-*-$FONTSIZE-*-*-*-*-*-*-*" -sr -sl 1024 -e
"/bin/bash --login -i -x" &

The rxvt window opens but hangs. I don't see the scroll bar and there are no
prompts. The window doesn't refresh, resize... nothing happens. I have to
kill it in order to get rid of it.
This script has worked for a long time and works on another machine which I
haven't upgraded yet.

My system is running WindowsXP-SP1

If i run the commands manually, everything works ok.

Thnks for your help

Thomas Fischer, MCSE              mailto:tvfischer@wanadoo.fr
     Apple, WinNT, e-Mail, Groupware

Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/

More information about the Cygwin mailing list