Problem with patch 2.5.8-7

Volker Quetschke
Sat Sep 6 20:52:00 GMT 2003


>>I'm experiencing problems with the current patch program, version
>>2.5.8-7. (System W2k, all binary mounts, Cygwin updated two hours ago.)
>>With the attached two files the following command worked with
>>previous versions of patch (still works if I go back to
>>patch 2.5.8-3 (my last version))
>>But now:
>>$ patch -i dos_lineends.patch -b -p2
>>vc_common.mak is in: ./STLport-4.0/src/vc_common.mak
> So it fails.  Interesting.  I wonder *how* it fails though. 
Ok, I stepped into the usual trap. If it fails for me, it has to fail for
you also :-(

Details follow:

$ ll
total 4
drwxrwxr-x+   3 q        none            0 Sep  6 22:42 STLport-4.0/
-rwxrwxr-x    1 admins   none         3737 Sep  6 22:41 dos_lineends.patch*
$ patch -i dos_lineends.patch -b -p2
patching file STLport-4.0/src/vc_common.mak
Hunk #1 FAILED at 42.
Hunk #2 FAILED at 53.
Hunk #3 FAILED at 63.
3 out of 3 hunks FAILED -- saving rejects to file STLport-4.0/src/vc_common.mak.rej

This time I attached the output of cygcheck -s -v -r.

As a data point, if I do a
$ dos2unix.exe STLport-4.0/src/vc_common.mak
first, the patch applies cleanly, but this is wrong,
both patch and file are DOS style files with 0D0A lineendings.

> P.S.: I tried it and it works for me.
It works if I use patch 2.5.8-3


PGP/GPG key  (ID: 0x9F8A785D)  available  from
key-fingerprint 550D F17E B082 A3E9 F913  9E53 3D35 C9BA 9F8A 785D
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 251 bytes
Desc: not available
URL: <>

More information about the Cygwin mailing list