bug in "ar" when creating libraries on cross linked filesystems

Ronald Landheer-Cieslak blytkerchan@users.sourceforge.net
Fri Sep 5 14:15:00 GMT 2003


I can't reproduce the problem and don't see anything out of the ordinary in
your cygcheck output.
Could you do a
$ which ar
and see if you're really working with Cygwin's ar?

(I've just read Igor's reply - interesting hunch, but I'd have expected to
be able to reproduce the problem..)

rlc

On Fri, Sep 05, 2003 at 01:48:34PM +0200, daniel.hempel@philips.com wrote:
> Sorry ... I forgot to attach the informations about my system.
> 
> I have the problem, that the command "ar" does work on "mounted" partitions.
>   ar cq libdh.a a.o b.o
> does not work, if the current directory is on a linked filesystem.
> The error message of "ar" is:
>    ar: libdh.a: rename: Cross-device link
>    make: *** [libdh.a] Error 1
> 
> The program works, when using local files, e.g. /usr/src or /cygdrive/c.
> In the case described above the current directory "." referes
> to /cygdrive/h which is mounted with the "Services for Unix" tools from
> Microsoft (Version 3.0).
> The operating system is Windows XP Professional. I installed cygwin
> version 1.5.3(0.90/3/2):
> 
> # uname -a
> CYGWIN_NT-5.1 PCHEMPEL2 1.5.3(0.90/3/2) 2003-09-01 13:15 i686 unknown unknown Cygwin
> 
> 
> Thanks for your help
> Daniel
> 
> 
> (See attached file: cygcheck.out)
> 


> --
> Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
> Problem reports:       http://cygwin.com/problems.html
> Documentation:         http://cygwin.com/docs.html
> FAQ:                   http://cygwin.com/faq/

-- 
Love thy neighbor, tune thy piano.

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list