[SPAMBayesian] - cygwin sshd on Windows Server 2003 Domain Controller? - Failed Bayesian filter

Christopher Faylor cgf-rcm@cygwin.com
Thu Sep 4 15:25:00 GMT 2003

[what's all the crap in the subject?]
On Thu, Sep 04, 2003 at 04:56:46PM +0200, Fermin Sanchez wrote:
>I used to have cygwin sshd running on my old Windows 2000 Domain 
>Controller, worked like a charm. Some time ago I switched (reinstalled, 
>actually) my domain controller to Windows Server 2003.
>I went through the usual steps: download, "ssh-host-config -y", security 
>model "ntsec" and installed it as a service. First, it worked for about 5 
>minutes. Then, when I tried to connect from a remote host, I got a network 
>connection error. The server isn't accepting connections any more. 
>Restarting the sshd service in windows results in:
>"The CYGWIN sshd service on Local Computer started and then stopped. Some 
>services stop automatically if they have no work to do, for example, the 
>Performance Logs and Alerts service".
>Needless to say, I don't think the sshd has nothing to do ...
>The windows event log has a bit more informations:
>sshd : PID 5648: socket: Operation not permitted.
>sshd : PID 5648: fatal: Cannot bind any address..
>sshd : PID 3508: starting service 'sshd' failed: execv: 255, error 255
>sshd : PID 3508: 'sshd' service stopped.
>/var/log/sshd.log shows:
>c:\cygwin\usr\sbin\sshd.exe: *** could not load user32, Win32 error 0
>This is the only entry in this file, regardless of how many times I try to 
>restart the service.

Just a hunch but I suspect that if you restart your system things will
work differently.

Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/

More information about the Cygwin mailing list