[ANNOUNCEMENT] Updated: cygutils-1.2.1-2 [Requires cygwin-1.5.3+]

Charles Wilson cwilson@ece.gatech.edu
Wed Sep 3 07:38:00 GMT 2003


cygutils provides a collection of small -- and hopefully useful --
utilities.


This release is built against the cygwin-1.5.x kernel; it will not work 
with 1.3.22.


CHANGES:

* Compiled against the 1.5.2 kernel.

* Documentation moved to /usr/share/*

* Added ipcs.exe, ipcrm.exe (with man pages).  These programs
   previously were part of the cygipc package. However, once cygserver
   is ready, these should also be compile-able against it.  So, this
   is a forward-looking addition.  At present, these apps are linked
   against the cygcygipc-2.dll shared version of the cygipc library.

* ipck script moved from the cygipc package to here.

* Now actually compile the semtool, shmtool, msgtool, and semstat
    programs.  Previously, because cygipc was not an official package,
    I did not actually include these binaries in the distribution,
    even though the cygutils source package contained them (they
    require libcygipc to build; but should also work with cygserver
    when the time comes).  Again, these apps are linked against the
    cygcygipc-2.dll shared version of the cygipc library.

* compiled against the cygipc-2.01-2 *shared* libcygipc.

* Because cygipc is now a DLL, we SHOULD list cygipc as a requirement
   for cygutils.  But, I don't really want to force everyone who wants
   lpr.exe to download cygipc.  So, I do NOT list cygipc as a requires:
   for this pacakge -- it shouldn't matter, anyway: the other progs
   will be fine without libcygipc, and the ipc tools don't work anyway
   if ipc-daemon2.exe isn't running even if it IS installed.  But, the
   only way for ipc-daemon2.exe to run, is if libcygipc is installed.
   So, we're covered.

Note that the ipcs and ipcrm source code is the version that originated
from cygipc, which is different from that provided in the util-linux
package on most linux systems.  Later on, I may consider switching over
to util-linux-derived code; but that can wait.

-- 
Charles Wilson
cygutils volunteer maintainer for cygwin

To update your installation, click on the "Install Cygwin now" link on
the http://cygwin.com/ web page.  This downloads setup.exe to your
system.  Then, run setup and answer all of the questions.

               *** CYGWIN-ANNOUNCE UNSUBSCRIBE INFO ***

If you want to unsubscribe from the cygwin-announce mailing list, look
at the "List-Unsubscribe: " tag in the email header of this message.
Send email to the address specified there.  It will be in the format:

cygwin-announce-unsubscribe-you=yourdomain.com@cygwin.com

If you need more information on unsubscribing, start reading here:

http://sources.redhat.com/lists.html#unsubscribe-simple

Please read *all* of the information on unsubscribing that is available
starting at the above URL.



--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list