Append: file contains ^M characters for binmode mount

Larry Hall (RFK Partners, Inc)
Tue Apr 23 06:53:00 GMT 2002

At 06:33 AM 4/23/2002, lau bella wrote:
>Hi all,
>Append to previous message, i found somethings:
>1/ When i run bash script in cygwin, e.g.
>    #!/bin/bash
>    echo "123" >> output_file
>    echo "456" >> output_file
>    echo "789" >> output_file
>    the output file is in unix mode, i.e. without ^M at
>the end of each line. 
>2/ When i run perl (cygwin perl), exp (export of
>oracle) and ftp in cygwin, the output files are in DOS
>format. When i vi the output files, the ^M is not
>appear in vi, but at the bottom of screen, it shows 
>"fileabc" [dos format] 3 lines, 209 characters
>Is the output_file generated by other software (e.g.
>oracle, perl) should generated as DOS mode, even run
>in cygwin ? But perl is bundled by cygwin.

Yep.  Historically, this has been an issue for Perl (from Cygwin).  I believe
the issue persists.  Check the email archives if you want more information.

Larry Hall                    
RFK Partners, Inc.            
838 Washington Street                   (508) 893-9779 - RFK Office
Holliston, MA 01746                     (508) 893-9889 - FAX

Unsubscribe info:
Bug reporting:

More information about the Cygwin mailing list