How I solved: "When I telnet to my machine I get 'bash.exe: The Application can't be initialized correctly (0x0000022)'"

Danilo Turina
Mon Apr 8 09:05:00 GMT 2002

Hope this can help someone.

The scenario
WinNT4.0SP6a, Cygwin 13.3.20 up to date for almost all packages 
obtainable by setup.exe (with the exception of Ghostscript, Dejagnu, 
links, postgresql, tetex and all of the *-devel packages).
Machine belongs to domain MYDOMAIN and I use MYDOMAIN\MYUSER to log to 
the machine. MYUSER has been added to the MYMACHINE\Administrators group.
Cygwin was installed using MYMACHINE\administrator (even if since 2 or 3 
months I update it through MYUSER).
Inetd correctly installed as package, installed as service and started 
(I followed the instructions in /usr/doc/Cygwin/inetutils-1.3.2.README).

The problem
When I try to telnet to MYMACHINE from another machine (or from itself), 
all works correctly until I insert username and password, then, if 
username and/or password is wrong, I must reinsert them (as usual), but 
if username and password are right I see motd and then (on MYMACHINE) a 
dialog with this message (or a very similar one) is displayed "bash.exe: 
The Application can't be initialized correctly (0x0000022)".

A workaround
Trying to change bash.exe with another application (I tried sh.exe, 
fortune and others) will not work. Therefore is not a bash problem.
It's very probable that:
  * it's not an inetd problem: the problem arises after inetd has done 
its job;
  * it's not a login/logind problem: i tried also with rsh, rexec and 
rlogin but none of them succeeded.
Some time ago, all worked so I guess that some component I upgraded is 
causing the problem. Unfortunately I rarely telnet to my machine, 
instead I use it as an X Server (XFree 4.2.0), so I can't determine when 
this happened.

Proceeding with trials and errors I discovered that downgrading from 
Cygwin 1.3.10-1 to Cygwin 1.3.9-1, will make the whole thing work. So 
for me, at least at the moment, this can be a solution.

The REAL solution
When trying to solve this problem I messed with mkpasswd and mkgroup, as 
a result this morning I was not able to start XFree anymore, in that 
ssh-agent claimed that it can't start because of some sort or permission 
Then I realized that even if I was logging to my machine as 
MYDOMAIN\MYUSER when I opened a local shell I was taken into  
MYMACHINE\administrator home (i.e. /home/administrator) (!!!). 
Nevertheless I was not MYMACHINE\administrator, infact when I created 
files they belonged to MYDOMAIN\MYUSER.
This was probably the problem.
I followed these steps:
  * regeneration of /etc/passwd and /etc/group with mkpasswd and mkgroup 
only for local users/groups;
  * insertion of MYDOMAIN\MYUSER into /etc/passwd with the command:

      mkpasswd -u MYUSER -d MYDOMAN >> /etc/passwd
    (this because MYDOMAIN contains thousands of users and generation a 
/etc/passwd file with all those users shouldn't be very useful for me);
  * update to Cygwin 1.3.10-1;
  * reboot (I don't know if this is needed).

After doing so, ssh-agent works again and now (eureka!) telnet does.

Ad said by many people of the Cygwin list, it was a permission problem.

Danilo Turina
Alcatel Optics TND Network Management
Rieti (Italy) - Phone: +39 746 600332

11 mesi 29 giorni 2 ore 52 minuti 41 secondi

Unsubscribe info:
Bug reporting:

More information about the Cygwin mailing list