Infinite Loop In "rm -fr" When Busy File Encountered

Randall R Schulz rrschulz@cris.com
Sat Apr 6 09:28:00 GMT 2002


Chris,

At 09:26 2002-04-06, Chris January wrote:
> > Greetings,
> >
> > I have encountered a problem in "rm" when used with the "-f" and "-r"
> > options and a busy and hence unremovable file is encountered.
> >
> > When "rm -fr" encounters a busy and hence unremovable file, it goes into an
> > infinite loop consuming as much CPU time as it can get until it is forcibly
> > terminated. The error is completely repeatable as long as the file remains
> > busy by virtue of being open in another program.
> >
> > The file system is NTFS and the mount is binmode. The system is Windows
> > 2000 Pro with SP2 and security patches installed.
> >
> > This is an up-to-date Cygwin installation that is exhibiting no other
> > anomalous behavior.
> >
> > In reference to the attached "cygcheck -rs" output, this happened on "C:"
> > "/cygdrive/c" (reached via a symlink "/c -> /cygdrive/c").
>
>I tried exhaustively to reproduce this (cygwin1.dll v1.3.10), but failed.


"Exhaustively?" In such little time?

Please tell me what you tried. I believe when it happened to me the file 
triggering the problem was open for writing.

Randall Schulz


>Chris


--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Bug reporting:         http://cygwin.com/bugs.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list