Possible Workaround - SSH/SSHD: could not chdir to home directory: No such file or directory

Corinna Vinschen cygwin@cygwin.com
Fri Apr 5 01:25:00 GMT 2002

On Fri, Apr 05, 2002 at 02:01:52AM -0600, Philip Flip Kromer wrote:
> Hello,
> I followed the recipe for setting up sshd under cygwin at
> 	http://tech.erdelynet.com/cygwin-sshd.asp
> Everything worked swimmingly, except..
>   tick:~$ ssh me@localhost
>   me@localhost's password:
>   Fanfare!!!
>   You are successfully logged in to this server!!!
>   Could not chdir to home directory /h/me: No such file or directory
> ..for the error message about not being able to find the home directory. 
> sshd would still log me in, and would still set me in my home directory 
> (which does exist).  The only problem (besides just annoyance) is that 
> it also would not find my ~/.ssh to do RSA authentication with.
> Some other people have reported this error; see
>   http://www.cygwin.com/ml/cygwin/1999-09/msg00276.html
>   http://www.cygwin.com/ml/cygwin/2000-09/msg00032.html
>   http://www.cygwin.com/ml/cygwin/2000-10/msg00758.html
>   http://www.cygwin.com/ml/cygwin/2000-11/msg01274.html
> Nobody seems to have posted a fix or reason for the error; but if I run 
> sshd under my account, rather than the SYSTEM account, it finds the home 
> directories and RSA authentication works.

Sure has this been discussed.  Is /h a remote drive?  If so,
SYSTEM isn't able to access it.


Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Developer                                mailto:cygwin@cygwin.com
Red Hat, Inc.

Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Bug reporting:         http://cygwin.com/bugs.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/

More information about the Cygwin mailing list