crypt command

Richard Campbell
Wed Apr 3 12:25:00 GMT 2002

>If the Cygwin build ends up trying to pull in Mingw header files, the 
>configuration of the package is wrong.  That could be a package problem 
>though.  I expect it's just an indicator of a configuration issue.  The 
>segv would be another.

The mhash package is definitely intended to be built under mingw, which 
seems to be failing.  It includes "ctype.h" under it's standard c libraries
list, which seems to have problems under mingw.

I actually reuntarred and tried building again.

If I comment out all references to ctype.h, the package builds cleanly, 
but fails with what is actually a "Signal 11".

I tried stepping through with gdb, but the area of code that is playing 
around here seems to be some interesting macros.

At this point previously, I hoped it was something I had done to get the 
compile to be clean, but considering that this time around I didn't change
any code (simply removed an include), I believe it's the mhash library's
fault, but I don't know enough to procede.

-Richard Campbell.

Unsubscribe info:
Bug reporting:

More information about the Cygwin mailing list