Installing cygwin gcc using sources

Robert McNulty Junior
Sat Jun 30 03:21:00 GMT 2001

Did you try configure?

-----Original Message-----
[]On Behalf Of deepak shekhar
Sent: Saturday, June 30, 2001 2:49 AM
Subject: Installing cygwin gcc using sources

Hi! there

I have installed the cygwin on my i586-pc having windows using the binaries
and the "setup.exe" program.
Now i am trying to install binutils and gcc using the sources.
My directory structure is like this
/home/deepak/sources - this is the directory containing the sources for
binuitls and gcc.
/home/deepak/build - object directory where i'll run configure and make.
/home/deepak/exe - install directory.

The versions of binutils is binutils-20010425-2-src.tar-gz and of gcc is

I have untared these packages in the sources directory.

In the build directory i run the configure for binutils by giving the
following command.
$cd build
$../sources/binutils-20010425-2/configure --prefix=/home/deepak/exe -v
Then i do a make.
 $make all && make install
The utilities in the binutils get installed.(including the as.exe and
Now i run configure for the gcc by the following command.

$../sources/gcc-2.95.3-4/configure --prefix=/home/deepak/exe -v

The configure is fine.
Now if do a make by giving
$make all

I get a following error messages and the make fails.

make[3]: Entering directory `/home/deepak/build/binutils'
/bin/sh ./libtool --mode=link gcc -W -Wall -g -O2  -o objdump.exe  objdump.o
bg.o rddbg.o debug.o stabs.o ieee.o rdcoff.o bucomm.o version.o filemode.o
codes/ ../bfd/ ../libiberty/libiberty.a
gcc -W -Wall -g -O2 -o objdump.exe objdump.o prdbg.o rddbg.o debug.o stabs.o
e.o rdcoff.o bucomm.o version.o filemode.o  ../opcodes/.libs/libopcodes.a
/.libs/libbfd.a ../libiberty/libiberty.a ./../intl/libintl.a
objdump.o: In function `main':
:2856: undefined reference to `cplus_demangle_name_to_style'
:2861: undefined reference to `cplus_demangle_set_style'
collect2: ld returned 1 exit status
make[3]: *** [objdump.exe] Error 1
make[3]: Leaving directory `/home/deepak/build/binutils'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/deepak/build/binutils'
make[1]: *** [all-recursive-am] Error 2
make[1]: Leaving directory `/home/deepak/build/binutils'
make: *** [all-binutils] Error 2

Is the method i am following to install from the sources is wrong??? Or
anyhting i am missing out???
Can somebody who have already installed "gcc" using the sources please help
me out in this.

thanks in advance

Buy Feng Shui Package for Rs. 151/- only, at

Unsubscribe info:
Bug reporting:

Unsubscribe info:
Bug reporting:

More information about the Cygwin mailing list