How I got ssh to work, and sshd to work from the command line on NT

Clark Sims
Thu Jun 28 09:25:00 GMT 2001

I have had a number of problems getting ssh/sshd to work and I have posted
the problems in this mail list. I have everything working now, (except that
I havn't installed sshd as a service). The steps where:

1) I deleted my cygwin directory, and removed cygwin from the destop.
2) I reinstalled from the internet
3) I had to create the home and user names by hand
mkdir /home
mkdir /home/Administrator
4) I opened the file /usr/doc/Cygwin/openssh-2.9p1.README in emacs
5) following the instructions I ran:
       /usr/bin/ssh-host-config  -d
      /usr/bin/ssh-user-config -d

I included the -d option becuase initially the files did not run correctly.
I had to go back and create the home directory before I could get them to
run correctly.

6) from a bash box
cd /usr/sbin
./sshd.exe -d

7) from another bash box
ssh -l Administrator localhost

and it worked

8) I tried adding the appropriate public keys to the authorized_keys file in
the /home/Administrator/.ssh directory,  but to no avail, I could not log in
from another machine.
In order to log in from another machine I had to change the sshd_config "To
install for logon to different user accounts"

diff sshd_config sshd_config~

< RSAAuthentication no
> RSAAuthentication yes
< PasswordAuthentication yes
> PasswordAuthentication no

9) from a bash box on the first nt box
./sshd.exe -d

10) from a bash box on another nt box
ssh -l Administrator   first.comp.ip.address

where first.comp.ip.address, is the first computers ip address

11) I am then prompted for a pass word, and I can log in

12) from a bash box on the first nt box
./sshd.exe -d

13) from a linux box
ssh -l Administrator first.comp.ip.address

I could then log in!   Linux was talking to NT!

It looks like everything is working perfect!

Unsubscribe info:
Bug reporting:

More information about the Cygwin mailing list