Build of Perl Tk with Cygwin fails

Rich Marshall
Fri Jun 15 22:26:00 GMT 2001


I recently installed cygwin 1.3.2-1 and perl 5.6.1.  I have installed
several perl modules, but ran into a problem with Tk 800.023.

First I ran into several problem, but worked around them by changing
  -I/usr/lib/include to -I/usr/include -I/home/Default/Tk/pTk/mTk/xlib
and adding
  -L/usr/lib -L/usr/lib/w32api

Now it fails building Tk.dll with several `undefined references.'

  tkGlue.o(.text+0x3f80):tkGlue.c: undefined reference to `TkwinVGet'
  tkGlue.o(.text+0x3f95):tkGlue.c: undefined reference to `TkwinintVGet'
  pTk/libpTk.a(tkSelect.o)(.text+0x111):tkSelect.c: undefined reference to
  pTk/libpTk.a(tkSelect.o)(.text+0x7a5):tkSelect.c: undefined reference to
  pTk/libpTk.a(tkWinWindow.o)(.text+0x26f):tkWinWindow.c: undefined
reference to `TkPointerDeadWindow'
  pTk/libpTk.a(tkWinPointer.o)(.text+0x13a):tkWinPointer.c: undefined
reference to `Tk_UpdatePointer'
  collect2: ld returned 1 exit status

Any suggestions?  Where should it find `TkwinVGet'?

Thanks in advanced.

Rich Marshall.

Want to unsubscribe from this list?
Check out:

More information about the Cygwin mailing list