sshd & cygrunsrv

Jason Dufair
Fri Jun 15 10:10:00 GMT 2001

Hello all -

First things first - Thank god for cygwin - I love it!

I've recently tried to get sshd running on Win2K sp2, OpenSSH v2.9p1 
Cygwin DLL v1.3.2 .  When I run it from bash (i.e., just type 
/usr/sbin/sshd) all seems well - I can ssh, scp from a remote machine 
using public/private key pairs (I have version 1 and 2 keys installed). 
 When I install it as a service using

cygrunsrv -I sshd -p /usr/sbin/sshd -a "-D -e"

The service seems to install, start, and stop OK, but I cannot 
authenticate to it, either via localhost or via the remote machine.  I 
get "permission denied (publickey, keyboard-interactive).  I looked at 
the logs and used -v on the client, but found nothing that jumped out at 
me.  I'd be glad to post them if need be.  I suspect it may have 
something to do with environment vars running as a service.  Anyone have 
any suggestions on how to troubleshoot further?  TIA.

(Many thanks especially to Corrina for cygrunsrv - sorry to send 
privately earlier, Corrina)

Jason Dufair -
"In matters of style, swim with the current; 
in matters of principle, stand like a rock."
-- Thomas Jefferson

Want to unsubscribe from this list?
Check out:

More information about the Cygwin mailing list