Which version of Libtool to use? (or is libtool impossible)

Christof Petig christof@petig-baender.de
Fri Jun 15 08:23:00 GMT 2001


I recently installed the most recent libtool available:

$ libtool --version
ltmain.sh (GNU libtool) 1.4 (1.920 2001/04/24 23:26:18)

and tried to compile libiconv-1.6.1 (prerequisite for glib)

Since I need a dynamic library I replaced 'enable_win32_dll=no' by
'=yes' in autoconf/ltconfig.

Everything went fine so far but as it tried to link against the newly
built .dll I get:
gcc -O -I. -I. -I../include -I./../include -I../lib ./iconv.c
../lib/.libs/libiconv.a -o .libs/iconv -Wl,--rpath -Wl,/usr/local/lib
/cygdrive/c/WINDOWS/TEMP/ccUWkOog.o(.text+0x192):iconv.c: undefined
reference to `_libiconv_version'
/cygdrive/c/WINDOWS/TEMP/ccUWkOog.o(.text+0x19d):iconv.c: undefined
reference to `_libiconv_version'

but:
$ nm lib/.libs/libiconv.a  | fgrep version
00000000 I __imp___libiconv_version

and
$ fgrep version lib/.libs/libiconv.exp
        _libiconv_version DATA

I'm confused.
   Christof



--
Want to unsubscribe from this list?
Check out: http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list