Broken regcomp() in Cygwin ?

Dr. Volker Zell
Fri Jun 8 02:20:00 GMT 2001

Hi all

I tried compiling urlview

[`urlview' is a curses program for extracting URLs from text files and
displaying a menu from which you can select a specific URL to view using
your favorite browser program.] (from the author)

 o urlview-0.9 -

for use with mutt with the following macro definitions in ~/.muttrc
macro index \cb |urlview\n
macro pager \cb |urlview\n

Configure, make, make install went smoothly.
But an invocation of urlview with an html file with embedded links brought me back to
the bash prompt with an exit status of 1. Running it under gdb shows it exits when compiling
a regexp. Here is the code:

  /*** compile the regexp ***/

  if ((i = regcomp (&rx, regexp, REG_EXTENDED | REG_ICASE | REG_NEWLINE)))
    regerror (i, &rx, buf, sizeof (buf));
    regfree (&rx);
    puts (buf);
    exit (1);                    <-------- Here it exits

The same source compiles and runs fine under linux.

So I tried compiling it with GNU rx (compiles OOTB)

 o rx-1.5 -

This time the resulting urlview works like a charm.

Is there any regex guru out there who can shed a light on this one ?


Want to unsubscribe from this list?
Check out:

More information about the Cygwin mailing list