OpenSSH broken with cygwin-1.3.2, w32api-20010520

Stephen Bailey
Tue Jun 5 15:05:00 GMT 2001


Thanks for the response.

Your patch seems to fix the runaway CPU at the end of the command,
and, editorially, I think I've seen similar buggy behavior with select
in code that I've ported, but it does not fix the real, initial
problem.  The initial problem is reported as can't set tty pgrp: not
owner.  As I mentioned, this problem was introduced between 1.3.1 and

I'd be perfectly happyto take an out-of-the-box solution.  I'm using
the command to invoke X clients on a remote machine, and I don't want
to tie up my shell.  Clearly -X is required, and in order to get my
shell prompt back, I use -f.  I actually would prefer being able to
run the ssh command without a Windows console window (or shell) at
all, but I have not been able to do that.  Any suggestions?

For example, I run:

  % ssh -f -X myhost xterm -T myhost -n myhost &

to get an xterm on myhost.  With this approach (which worked until
1.3.2) it's still annoying that I can't exit my shell until the xterm
has exited.


Want to unsubscribe from this list?
Check out:

More information about the Cygwin mailing list