inetd under Win95 OSR2.5

Corinna Vinschen cygwin@cygwin.com
Tue Jun 5 06:45:00 GMT 2001


On Tue, Jun 05, 2001 at 01:05:27PM +0100, Tim Chick wrote:
> I am tyring to use telnetd via inetd under Win95.
> 
> Has anyone had this working under Win95?
> 
> I have set this up under Win2k and it works fine.
> 
> I run inetd as
> # /usr/sbin/inetd -d
> 
> All the services seem to be registered correctly.
> 
> When I connect to an internal service, eg daytime, I get the
> expected response, and the following output from inetd:
> 
> someone wants daytime
> accept, ctrl is 3
> 
> When I connect to telnet, it makes a coonection but I get no
> login prompt. The output from inetd is:
> 
> someone wants telnet
> accept, ctrl 3
> + Closing from 21
> 139545 execl /usr/sbin/in.telnetd
> 139545 reaped, status 0x100
> 
> The exec and reaped line are printed straight after each other.
> 
> If I try /usr/sbin/in.telnetd -debug , without the inetd. I get:
> /usr/sbin/in.telnetd.exe: getpeername: The descriptor is a file, not a
> socket
> 
> Is this a problem with Win95 Winsock?
> 
> I am using cygwin dll v1.3.2-1 and inetutils 1.3.2-14

Is that a problem with your installation? You need the login package
installed as well.

Corinna

-- 
Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Developer                                mailto:cygwin@cygwin.com
Red Hat, Inc.

--
Want to unsubscribe from this list?
Check out: http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list