1.3.2: Troubles with Makefile.in.in

Jens F. Acker jacker@dorf.wh.uni-dortmund.de
Sat Jun 2 10:31:00 GMT 2001

I have a problem with certain configure scripts trying to generate
a Makefile.in file from a Makefile.in.in file. Its always the same
creating lib-src/Makefile.in
sed: can't read /home/jacker/source/xemacs-21.1.14/lib-src/Makefile.in.in: No
 such file or directory
creating src/Makefile.in
sed: can't read /home/jacker/source/xemacs-21.1.14/src/Makefile.in.in: No such
 file or directory

After that the Makefile.in.in file disappeared and the Makefile.in has zero
bytes filesize. When the source tree was extracted, there was file named
Makefile.in.in. But when I try to tinker around with Makefile.in and
Makefile.in.in by editing and saving them, both files seems to 'collide',
sort of. A smaller example than the above is with the very small editor nano 
V1.0.0 available from ftp.gnu.org. If I try to compile the international
language support into it, I get the same problem with po/Makefile.in.in.
Whenever I run into a configure scripts that uses this two stage approach
(Makefile.in.in->Makefile.in and later Makefile.in->Makefile) I had this
problem. Can someone beside me reproduce this error ?
I tried to work around it, by partially rewriting the configure script
and renaming Makefile.in.in to Makefile.in. Then Makefile.in->Makefile,
rename Makefile->Makefile.in. And then Makefile.in->Makefile, but I only
succeded with nano because this task got suprisingly complex with larger
You will find a copy of cygcheck.out attached to this mail.

Cygnus Win95/NT Configuration Diagnostics
Current System Time: Sat Jun  2 18:59:53 2001

Win9X Ver 4.10 build 67766446  A 

Path:	/usr/local/bin


PWD = `/home/jacker'
USER = `jacker'
MAKE_MODE = `unix'
HOME = `/home/jacker'

PROMPT = `$p$g'
!C: = `C:\cygwin\bin'
CMDLINE = `bash --login -i'
CLASSPATH = `C:\WINDOWS\SYSTEM\QTJava.zip;C:\Programme\Exceed.95;'
PS1 = `\e[34m\]\w\[\e[0m\]> '
BLASTER = `A220 I7 D1 T2 '
MACHTYPE = `i686-pc-cygwin'
LC_ALL = `de'
OLDPWD = `/home/jacker/source'
TEMP = `/cygdrive/c/WINDOWS/TEMP'
SHLVL = `1'
SHELL = `/bin/bash'
HOSTTYPE = `i686'
OSTYPE = `cygwin'
TERM = `cygwin'
PGDATA = `/usr/share/postgresql/data'
_ = `/usr/bin/cygcheck.exe'
TZ = `MEZMZ-1MEZMS-2,M3.5.0/2,M10.5.0/3'

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\MenuOrder\Start Menu\&Programs\Cygnus Solutions
  (default) = (unsupported type)
HKEY_CURRENT_USER\Software\Cygnus Solutions
HKEY_CURRENT_USER\Software\Cygnus Solutions\Cygwin
HKEY_CURRENT_USER\Software\Cygnus Solutions\Cygwin\mounts v2
  (default) = `/cygdrive'
  cygdrive flags = 0x00000022
HKEY_CURRENT_USER\Software\Cygnus Solutions\Cygwin\Program Options
HKEY_LOCAL_MACHINE\Software\Cygnus Solutions
HKEY_LOCAL_MACHINE\Software\Cygnus Solutions\Cygwin
HKEY_LOCAL_MACHINE\Software\Cygnus Solutions\Cygwin\mounts v2
HKEY_LOCAL_MACHINE\Software\Cygnus Solutions\Cygwin\mounts v2\/
  (default) = `C:/cygwin'
  flags = 0x0000000a
HKEY_LOCAL_MACHINE\Software\Cygnus Solutions\Cygwin\mounts v2\/usr/bin
  (default) = `C:/cygwin/bin'
  flags = 0x0000000a
HKEY_LOCAL_MACHINE\Software\Cygnus Solutions\Cygwin\mounts v2\/usr/lib
  (default) = `C:/cygwin/lib'
  flags = 0x0000000a
HKEY_LOCAL_MACHINE\Software\Cygnus Solutions\Cygwin\Program Options

a:  fd           N/A    N/A                    
c:  hd  FAT32   6161Mb  89% CP    UN           PLATTE 1
d:  hd  FAT32   4117Mb  90% CP    UN           PLATTE 2
e:  cd           N/A    N/A                    

C:\cygwin\bin  /usr/bin  system  binmode
C:\cygwin\lib  /usr/lib  system  binmode
C:\cygwin  /        system  binmode
c:    /cygdrive/c  user    binmode,noumount
d:    /cygdrive/d  user    binmode,noumount

Found: C:\cygwin\bin\bash.exe
Found: C:\cygwin\bin\cat.exe
Found: C:\cygwin\bin\cpp.exe
Found: C:\cygwin\bin\find.exe
Found: c:\WINDOWS\COMMAND\find.exe
Warning: C:\cygwin\bin\find.exe hides c:\WINDOWS\COMMAND\find.exe
Found: C:\cygwin\bin\gcc.exe
Found: c:\PROGRA~1\GNAT\BIN\gcc.exe
Warning: C:\cygwin\bin\gcc.exe hides c:\PROGRA~1\GNAT\BIN\gcc.exe
Found: C:\cygwin\bin\gdb.exe
Found: c:\PROGRA~1\GNAT\BIN\gdb.exe
Warning: C:\cygwin\bin\gdb.exe hides c:\PROGRA~1\GNAT\BIN\gdb.exe
Found: C:\cygwin\bin\ld.exe
Found: c:\PROGRA~1\GNAT\BIN\ld.exe
Warning: C:\cygwin\bin\ld.exe hides c:\PROGRA~1\GNAT\BIN\ld.exe
Found: C:\cygwin\bin\ls.exe
Found: C:\cygwin\bin\make.exe
Found: c:\PROGRA~1\GNAT\BIN\make.exe
Warning: C:\cygwin\bin\make.exe hides c:\PROGRA~1\GNAT\BIN\make.exe
Found: C:\cygwin\bin\sh.exe

   56k 2000/12/03 C:\cygwin\bin\cygbz21.0.dll - os=4.0 img=1.0 sys=4.0
                  "cygbz21.0.dll" v0.0 ts=2000/11/21 0:53
   81k 2001/04/28 C:\cygwin\bin\cygitcl30.dll - os=4.0 img=1.0 sys=4.0
                  "cygitcl30.dll" v0.0 ts=2001/4/29 0:57
   35k 2001/04/28 C:\cygwin\bin\cygitk30.dll - os=4.0 img=1.0 sys=4.0
                  "cygitk30.dll" v0.0 ts=2001/4/29 0:57
  390k 2001/04/28 C:\cygwin\bin\cygtcl80.dll - os=4.0 img=1.0 sys=4.0
                  "cygtcl80.dll" v0.0 ts=2001/4/29 0:56
    5k 2001/04/28 C:\cygwin\bin\cygtclpip80.dll - os=4.0 img=1.0 sys=4.0
   10k 2001/04/28 C:\cygwin\bin\cygtclreg80.dll - os=4.0 img=1.0 sys=4.0
                  "cygtclreg80.dll" v0.0 ts=2001/4/29 0:56
  623k 2001/04/28 C:\cygwin\bin\cygtk80.dll - os=4.0 img=1.0 sys=4.0
                  "cygtk80.dll" v0.0 ts=2001/4/29 0:57
   18k 2000/10/23 C:\cygwin\bin\cyggdbm.dll - os=4.0 img=1.0 sys=4.0
                  "cyggdbm.dll" v0.0 ts=2000/10/23 4:26
   14k 2000/10/23 C:\cygwin\bin\cygintl.dll - os=4.0 img=1.0 sys=4.0
                  "cygintl.dll" v0.0 ts=2000/10/23 21:02
   45k 2000/10/22 C:\cygwin\bin\cygjbig1.dll - os=4.0 img=1.0 sys=4.0
                  "cygjbig1.dll" v0.0 ts=2000/10/23 1:06
  119k 2000/10/22 C:\cygwin\bin\cygjpeg6b.dll - os=4.0 img=1.0 sys=4.0
                  "cygjpeg6b.dll" v0.0 ts=2000/10/23 2:58
  163k 2001/05/06 C:\cygwin\bin\cygpng2.dll - os=4.0 img=1.0 sys=4.0
                  "cygpng2.dll" v0.0 ts=2001/5/6 6:05
   45k 2001/04/25 C:\cygwin\bin\cygform5.dll - os=4.0 img=1.0 sys=4.0
                  "cygform5.dll" v0.0 ts=2001/4/25 7:28
   26k 2001/04/25 C:\cygwin\bin\cygmenu5.dll - os=4.0 img=1.0 sys=4.0
                  "cygmenu5.dll" v0.0 ts=2001/4/25 7:27
  156k 2001/04/25 C:\cygwin\bin\cygncurses++5.dll - os=4.0 img=1.0 sys=4.0
                  "cygncurses++5.dll" v0.0 ts=2001/4/25 7:29
  226k 2001/04/25 C:\cygwin\bin\cygncurses5.dll - os=4.0 img=1.0 sys=4.0
                  "cygncurses5.dll" v0.0 ts=2001/4/25 7:17
   15k 2001/04/25 C:\cygwin\bin\cygpanel5.dll - os=4.0 img=1.0 sys=4.0
                  "cygpanel5.dll" v0.0 ts=2001/4/25 7:27
   17k 2001/01/07 C:\cygwin\bin\cyghistory4.dll - os=4.0 img=1.0 sys=4.0
                  "cyghistory4.dll" v0.0 ts=2001/1/7 5:34
  108k 2001/01/07 C:\cygwin\bin\cygreadline4.dll - os=4.0 img=1.0 sys=4.0
                  "cygreadline4.dll" v0.0 ts=2001/1/7 5:34
  243k 2000/10/23 C:\cygwin\bin\cygtiff3.dll - os=4.0 img=1.0 sys=4.0
                  "cygtiff3.dll" v0.0 ts=2000/10/23 3:14
   41k 2001/05/28 C:\cygwin\bin\cygXpm-noX4.dll - os=4.0 img=1.0 sys=4.0
                  "cygXpm-noX4.dll" v0.0 ts=2001/5/28 19:57
   45k 2000/11/20 C:\cygwin\bin\cygXpm-X4.dll - os=4.0 img=1.0 sys=4.0
                  "cygXpm-X4.dll" v0.0 ts=2000/11/20 3:45
   49k 2001/02/03 C:\cygwin\bin\cygz.dll - os=4.0 img=1.0 sys=4.0
                  "cygz.dll" v0.0 ts=2001/2/3 21:35
  678k 2001/05/21 C:\cygwin\bin\cygwin1.dll - os=4.0 img=1.0 sys=4.0
                  "cygwin1.dll" v0.0 ts=2001/5/21 5:28
    Cygwin DLL version info:
        dll major: 1003
        dll minor: 2
        dll epoch: 19
        dll bad signal mask: 19005
        dll old termios: 5
        dll malloc env: 28
        api major: 0
        api minor: 39
        shared data: 3
        dll identifier: cygwin1
        mount registry: 2
        cygnus registry name: Cygnus Solutions
        cygwin registry name: Cygwin
        program options name: Program Options
        cygwin mount registry name: mounts v2
        cygdrive flags: cygdrive flags
        cygdrive prefix: cygdrive prefix
        cygdrive default prefix: 
        build date: Sun May 20 23:28:17 EDT 2001
        shared id: cygwin1S3

Use -h to see help about each section

More information about the Cygwin mailing list