Escape sequence "^[[1m" no longer makes console text bright

Christopher Faylor
Fri Jun 1 19:08:00 GMT 2001

On Fri, May 18, 2001 at 04:26:59PM -0400, Francis Litterio wrote:
>I upgraded from Cygwin 1.1.6 to 1.3.1 (under Windows 2000), and I notice
>that the console escape sequence generated by "tput bold" is no longer
>making text bright.  Here's what I see:
>  bash$ echo $TERM
>  cygwin
>  bash$ echo "hello $(tput bold)foo$(tput sgr0) there"
>  hello foo there             <== "foo" is normal; was bright in 1.1.6.
>  bash$ tput bold | od -c
>  0000000 033   [   1   m
>  0000004
>  bash$ tput sgr0 | od -c
>  0000000 033   [   0   ;   1   0   m
>  0000007
>I think this may be related to why I see all the highlighted keywords in
>man pages in half-bright mode instead of bright mode.  I'm not using a
>personal TERMINFO database -- just the one in /usr/share/terminfo.
>I could swear that this is the same escape sequence for "bold" that
>worked fine under Cygwin 1.1.6.  Could the Cygwin library be
>initializing the console differently somehow, so that the console
>interprets the "^[[1m" differently now?

I just tried this and ^[[1m correctly turned bold on for me.


Want to unsubscribe from this list?
Check out:

More information about the Cygwin mailing list