cygrunsrv fails to start

Corinna Vinschen cygwin@cygwin.com
Fri Jun 1 00:01:00 GMT 2001


On Thu, May 31, 2001 at 10:34:17PM -0700, Karl M wrote:
> Hi All...
> 
> An update. I have seen the timeouts when running cygrunsrv with a "--dep 
> EventLog". So the timeout can happen with or without the "--dep EventLog". 
> Sometimes it works, sometimes it doesn't.This was the executable off of the 
> mirrors, not one I was messing with.
> 
> If I add syslog statements, when it works I see log entries for all of them. 
> When it doesn't work, I see none of the log entries that I added. The first 
> one was just after the openlog call in service_main (and just before the 
> RegisterServiceCtrlHandlerA call). Sometimes it works, sometimes it doesn't.
> 
> I tried commenting out the openlog call and all of the syslog calls. 
> Sometimes it works, sometimes it doesn't.
> 
> If there were a problem with a dependency on some TCP/IP thing for the 
> socket, I think that would show up later when sshd connects to port 22.
> 
> I'm kind of limited in what I know how to do here...I'm basically doing 
> printfs with post-mortem analysis. I don't know what else to try. Any 
> thoughts?

I'm pretty sure it's a difference of the machines installation. Just
as an example, I had once a problem installing services which depend
on a prior started Oracle (some 7.x version) service. So I added
dependencies to the Oracle service to my services but that never worked.
The Oracle service didn't startup anymore and the SCM database stayed
locked! I had to change my code to loop until Oracle is available,
instead :-P

However, I have that automatic startup on two machines and both
startup as usual and always. But both are developer machines
which don't have any strange stuff installed (uh, except the OS
of course).

Corinna

-- 
Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Developer                                mailto:cygwin@cygwin.com
Red Hat, Inc.

--
Want to unsubscribe from this list?
Check out: http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list