Program can not be run in DOS mode

bob olbrich
Thu Jan 25 10:39:00 GMT 2001

"McCunney, Dennis" wrote:

> > -----Original Message-----
> > From: bob olbrich [ ]
> > Sent: Wednesday, January 24, 2001 5:49 PM
> > To:
> > Subject: Program can not be run in DOS mode
> I answered this breifly last night from home, but a closer inspection
> reveals the problem may not be what I assumed.
> >      I just came across Cygwin a few days ago, so I decided to try it.
> > Eventually, I got it to download and install successfully. However,
> > it does not want to boot.
> Did you install using the Cygwin setup program?  I ask because..
> >     The error in the subject occurs every time I use the shortcut on
> > my desktop. By using the step-by-step boot in Win98, I found
> > that the error occurs after the following line:
> ...the desktop shortcut _it_ creates...
> >      Call c:\windows\ /e:4096 /c c:\cygwin\cygwin.bat
> looks like this:
> c:\windows\ /e:4096 /c c:\cygwin\cygwin.bat
> >    Cygwin.bat looks like:
> >
> >        @echo off
> >
> >        C:
> >        chdir \cygwin\bin
> >
> >        bash --login -i
> That's fine.
> >     One more command is executed (c:\windows\ /wx)
> >  and the machine reboots to Windows. Can someone with more experience
> > help?
> Offhand, it _looks_ like you tried to set up Cygwin bash as a boot shell,
> run from AUTOEXEC.BAT.  You can't do that.  Cygwin bash is a 32 bit console
> mode application.  When you are booting, you are in DOS 7.0, which is still
> 16 bit.  The 32 bit protected mode services bash requires are part of the
> GUI, and aren't active until Windows loads and initializes.  You can run
> bash as a console mode app in a window _after_ Windows is running, but you
> can't boot into it.
> A few more details on just _how_ you downloaded and installed Cygwin would
> be nice.
> > Thanks,  Bob Olbrich
> ______
> Dennis

      I downloaded setup.exe from the cygwin page. I ran setup.exe, chose a mirror site, and
downloaded all of the contents. I ran setup again and chose to install from a local directory.
That completed with no errors. Finally, the desktop icon was produced. Have I missed
something? Are there some post-install steps to follow?


  I think I solved the problem! For the shortcut cygwin.pif "properties", "program",
"advanced" had MS-DOS mode checked. I unchecked this and checked "suggest MS-DOS mode
as necessary". This eliminated the attempted re-boot and put me in a window with the
$ prompt.


Want to unsubscribe from this list?
Check out:

More information about the Cygwin mailing list