su & login

Corinna Vinschen
Tue Jan 23 11:17:00 GMT 2001

On Tue, Jan 23, 2001 at 06:03:03PM +0000, Gerrit le Roux wrote:
> Whenever I tried to use login I get:
> login: no shell: /bin/bash: Permission denied
> It doesn't matter which shell I use (/bin/sh gives the same error), but
> I get logged in as that user if I used the other username to log onto NT
> - by running Cygwin it automatically logs me on as the user I am on NT.
> Also, I tried su:
> su: cannot set user id: Not owner.
> I am able to su with the same id as what I'm logged in as (bit useless,
> but it shows that su is working)
> It does check the password, because if I type in the wrong password, I
> get " login incorrect"
> The same happens with my root user, and Administrator. The only
> deviation is when using su ( and it assumes root) , then
> it tells me the password is incorrect. But I can log into NT with that
> password.

Read /usr/doc/Cygwin/inetutils-1.3.2.README. It contains some hints
related to user rights on NT etc.
Read the online documentation on ,
especially the ntsec chapter.


Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Developer                      
Red Hat, Inc.

Want to unsubscribe from this list?
Check out:

More information about the Cygwin mailing list