Cygwin commands crashes after ssh login

Corinna Vinschen
Thu Jan 18 08:18:00 GMT 2001

On Thu, Jan 18, 2001 at 10:22:55AM -0500, Yadin Goldschmidt wrote:
> Corinna,
> I tried both -1 and -2. I think the problem is with the cygwin dll
> since if I use 1.1.5 the problem disappears. What is also strange is
> that if I run sshd -d from a shell the problem does not occur. It only 
> occurs with sshd run from srvany. Please read carefully my setup
> 1., 2., 3. 4. in my previous mail, maybe you can reproduce it.

Same here. I _did_ read your mail!

> The CYGWIN variable ntsec, tty is defined in NT Control Panel ->system 
> ->environment. 

Ditto. (CYGWIN = binmode tty ntsec)

> ->environment. The files ssh_host_key and ssh_host_dsa_key have permissions 
> -rw------- and belong to user.Adminstrators.


No problem here using different accounts, using tcsh or bash as
login shell.

Note that I reinstalled Cygwin from scratch here! On my developer box!
I'm using the old ssh key files of course but everything else is fresh
and new including all mount points (now according to the installation
default). I'm using the 20001221 version of OpenSSH, though, which you
can install using setup.


Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Developer                      
Red Hat, Inc.

Want to unsubscribe from this list?
Check out:

More information about the Cygwin mailing list