Moving from textmode to binmode: mount: resource busy

David M. Karr
Fri Jan 12 12:37:00 GMT 2001

>>>>> "David" == David M Karr <> writes:
  David> I want to explore the possibility of using binmode instead of
  David> textmode.  I successfully changed the default to binmode.  When I
  David> tried changing the mode on "/usr/bin", in an MSDOS shell with:

  David>    mount -b -s d:\cygwin\bin /usr/bin

  David> It said:

  David>    mount: /usr/bin: Device or resource busy

  David> I'm doing this from the root directory of a different drive, and I've
  David> killed every process that could possibly (AFAIK) have this open.

  David> I'd appreciate some information about this.

  David> When I get past this, what other issues should I expect, and can I
  David> deal with them?  For instance, what do I have to do with "pdksh" and
  David> NTEmacs to work with this?

Thanks to DJ and Larry for the "mount" reminders.

I've now gotten my mounts set to binmode, and I figured out how to
make Emacs write everything in Unix text file mode.

I have an idea about how to deal with "ksh".  I tried moving "ksh.exe"
out of the way and adding a symlink from "bash.exe" to "ksh.exe".  I
tried some basic primitive tests, and this works fine, but is there
any place where this could cause me problems?

David M. Karr     ; w:(425)487-8312     ; TCSI & Best Consulting    ; Java/Unix/XML/C++/X ; BrainBench CJ12P (#12004)

Want to unsubscribe from this list?
Check out:

More information about the Cygwin mailing list