CR/LF problems,
Thu Jan 11 16:27:00 GMT 2001

On 11 Jan, Larry Hall (RFK Partners, Inc) wrote:
> At 06:25 PM 1/11/2001, wrote:
>>On 11 Jan, Earnie Boyd wrote:
>> > Mark Tigges wrote:
>> >>  
>> >> and when I installed I checked "Unix" as the default text file
>> >> mode.  However, as I said it seems to have no effect (I have tried
>> >> both tty and binmode in the CYGWIN variable (also  CYGWIN32 as I
>> >> saw sporadic mention of it in the user guide as well)).
>> >> 
>> >> I am at a complete loss as to what is causing the problem.  If
>> >> anybody knows how to effectively eradicate any \r\n translation
>> >> I would be hugely appreciated to be enlightened.
>> >> 
>> > 
>> > I'm at a complete loss too.  What shell are you using?  Send the output
>> > of `cygcheck -s -r -v' to the list.
>> > 
>>Thanks for the help.  I am using the standard shell that
>>one gets when executing the cygwin.bat, which seems to be bash.
>>I attached the cygcheck output.
>>Thanks again,
> The only problem I can see is you have a copy of cygwin1.dll in 
> c:\winnt\system32.  Get it out of there.  What command shows you the 
> problem?  Can you give a reproducible case?

There was some reason why I put it there before, but I can't remember
what it was.  Anyhow I erased it and it did not solve the problem.  I
made sure that I copied the new one in today when I upgraded cygwin.

All which I have tried have yielded negative results.

I programatically create files through a cygwin compiled python.
I 'cat > filename' a file (with new lines)
I create files with an editor (tried both xemacs and emacs)

All cases always create files with '\r\n'

Sorry to uninterested subscribers for creating undue amounts of traffic.


Want to unsubscribe from this list?
Check out:

More information about the Cygwin mailing list