Libtool problem under Cygwin!

clifftsai clifftsai@minecard.com.tw
Tue Jan 9 17:25:00 GMT 2001


How can I make sure which symbol is undefined in cygwin shared library?
Thanks!

----- Original Message -----
From: "Gary V. Vaughan" <gvv@techie.com>
To: "clifftsai" <clifftsai@sinamail.com>
Cc: <cygwin@sources.redhat.com>
Sent: Wednesday, January 10, 2001 3:16 AM
Subject: Re: Libtool problem under Cygwin!


> On Tue, Jan 09, 2001 at 05:38:52PM +0800, clifftsai wrote:
> >
> > Hi:
> >     I have a problem when using Libtool to create a Libtool Shared
Library.
> >
> >     $libtool gcc -rpath /usr/loca/lib -o libtrim.la trim.lo
> >       libtool: link :warning:undefined symbols not allowed in
i586-pc-cygwin shared libraries.
> >
> >       How can I solve this problem?
>
> $ libtool gcc -rpath /usr/loca/lib -no-undefined -o libtrim.la trim.lo
>
> You need to be sure that all the symbols in trim.lo really are defined
> before you do this, since you can't have runtime symbol resolution in
> Windows.
>
> Cheers,
> Gary.
> --
>   ___              _   ___   __              _         mailto:
gvv@techie.com
>  / __|__ _ _ ___ _| | / / | / /_ _ _  _ __ _| |_  __ _ ___
gary@gnu.org
> | (_ / _` | '_|// / |/ /| |/ / _` | || / _` | ' \/ _` | _ \
>  \___\__,_|_|\_, /|___(_)___/\__,_|\_,_\__, |_||_\__,_|//_/
> home page:  /___/                      /___/                  gpg public
key:
> http://www.oranda.demon.co.uk
http://www.oranda.demon.co.uk/key.asc
>
> --
> Want to unsubscribe from this list?
> Check out: http://cygwin.com/ml/#unsubscribe-simple
>
>



--
Want to unsubscribe from this list?
Check out: http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list