openssh and ~

Erdely, Michael
Mon Jan 8 08:39:00 GMT 2001

Make sure your home directory is set correctly in the /etc/passwd file:


----- Original Message -----
From: "CyberZombie" <>
To: "Cygwin" <>
Sent: Monday, January 8, 2001 11:35 AM
Subject: openssh and ~

> I am having a strange problem with ssh.  It appears that it is expanding
> home directory part of various path specs.  I.e., ~ is mapping to an empty
> string.  In order for me to connect to another maching, I have to put
> specific configuration files in /.ssh rather than ~/.ssh.  Additionally,
> when I run "ssh -v" I get a message "debug: key does not exist:
> /.ssh/id_rsa".  But /etc/ssh_config has the line "IdentityFile
> ~/.ssh/id_rsa".
> I'm running on NT 4sp6A.  Relevant environment variables are:
> HOME=/home/k02189
> CYGWIN= (also tried w/ CYGWIN=ntsec -- no difference)
> In order to get ssh to work, I have to add (either to /etc/ssh_config or
> specific connection in /.ssh/config) "IdentityFile
> /home/k02189/.ssh/id_rsa".  Any ideas?
> --
> Want to unsubscribe from this list?
> Check out:

Want to unsubscribe from this list?
Check out:

More information about the Cygwin mailing list