new install of cygwin with pdksh doesn't work

Larry Hall (RFK Partners, Inc)
Wed Jan 3 14:03:00 GMT 2001

At 12:53 PM 1/3/2001, David M. Karr wrote:
> >>>>> "Earnie" == Earnie Boyd <> writes:
>   Earnie> --- "Larry Hall (RFK Partners, Inc)" <> wrote:
>   >> 
>   >> >I guess this means that the default mode for unmapped directories is
>   >> >"text" on my original installation, and "binary" for the second
>   >> >installation.  Since directories like "d:/dmk" (my home directory) are
>   >> >not covered by the original mount table, I would get the default.
>   >> 
>   >> You should be able to reset your default mode for unmapped drives using
>   >> the --change-cygdrive-prefix setting for mount but specify the "-t" flag
>   >> too.  I haven't tried this myself so I don't know if it actually works.
>   Earnie> If you chose the "Everyone" radio button, add a -s to that.
>   >> >So, when I install it again, if I select the "DOS" text file type, I
>   >> >won't have to add this mount to get files on the "D:/" drive to use
>   >> >DOS text file mode, correct?
>   >> 
>   >> Right.
>   >> 
>   >> >What exactly in the "cygcheck" output (or any other place, for that
>   >> >matter) tells me what the default text file type is?
>   >> 
>   >> Nothing.  cygcheck doesn't output that yet.
>   Earnie> That's not true.  The output of the registry data can tell you.  0x00000020 is
>   Earnie> text mode 0x00000022 is binary mode.
>Sorry for needing to rehash this, but could someone tell me EXACTLY
>what I need to execute to permanently change the default text file
>type to DOS?  I've tried numerous variations of what's described here,
>and I can't get it to work on a third installation of this (where the
>user neglected to select "DOS" on the initial install).
>I've tried the following:
>mount -ts --change-cygdrive-prefix /cygdrive
>mount -ts --change-cygdrive-prefix /d
>mount -t --change-cygdrive-prefix /d
>These all just echo the usage message.

AFAICT, mount doesn't accept combined flag options, at least for 
--change-cygdrive-prefix.  Use -t -s.  Also its best to make sure that
you invoke the --change-cygdrive-prefix option without the -s flag, since
you may have set the option for your personal login to something other 
than text in your attempts.  Do the following:

mount -t -s --change-cygdrive-prefix /cygdrive
mount -t --change-cygdrive-prefix /cygdrive

That should do it.  BTW, I don't recommend using a path like "/d" for your
cygdrive path.  Since many people tend to mount their D: drive to /d, this
may become confusing for you.  Whatever suits you is fine, providing you 
understand what you're doing.

>After the following:
>       mount -t d: /d
>I get "mount: warning - /d does not exist".  Doing "mount" after this
>shows a new mount entry in textmode, but running "ksh" still gets the
>usual error.

As you said, you got the warning.  Mount really wants the POSIX path you 
mount to exist, but it doesn't force it to.  Type "mkdir /d" before the 
mount to remove this warning.

>David M. Karr     ; w:(425)487-8312     ; TCSI & Best Consulting
>    ; Java/Unix/XML/C++/X ; BrainBench CJ12P (#12004)

Larry Hall                    
RFK Partners, Inc.            
118 Washington Street                   (508) 893-9779 - RFK Office
Holliston, MA 01746                     (508) 893-9889 - FAX

Want to unsubscribe from this list?
Check out:

More information about the Cygwin mailing list